Something not quite right?
We appreciate your feedback. Reach out to us at info@jesusfilm.org, and we'll look into it promptly.
Resolved
The account registration issue has been successfully resolved. On behalf of the Next Steps team, we thank you for your patience and understanding.
Investigating
We are currently experiencing issues related to the creation of Next Steps Admin accounts. Please refrain from creating new accounts until further notice.