Resolved
Cloudflare has reported full services restored at Nov 19, 2025 – 08:28 NZDT (UTC+13)
Monitoring
Cloudflare has identified the issue and a fix is being implemented on their end.
We will provide further updates during New Zealand work hours (~6 hours from now).
Monitoring
We've been informed by Cloudflare that they are seeing their services recover, but we may continue to observe higher-than-normal error rates as Cloudflare continues remediation efforts.
We will continue routine monitoring and provide updates as we hear from Cloudflare. In the meantime you might intermittent experience outages on https://www.jesusfilm.org and https://www.jesusfilm.org/watch.
Cloudflare Status Page
Thank you for your patience during this incident.
Monitoring
We're currently experiencing a service disruption with Cloudflare's platform. According to their status page:
Cloudflare is aware of, and investigating an issue which impacts multiple customers: Widespread 500 errors, Cloudflare Dashboard and API also failing.
We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Impact on https://www.jesusfilm.org and https://www.jesusfilm.org/watch
Because our system depends on Cloudflare, https://www.jesusfilm.org/ and https://www.jesusfilm.org/watch is not accessible at this time.
What We're Doing
We're closely following the updates from the Cloudflare status page to see if there is a work-around to bring our services back up.
Something not quite right?
We appreciate your feedback. Reach out to us at info@jesusfilm.org, and we'll look into it promptly.