LaunchDarkly Dependency Disruption Impacting NextSteps Admin
Resolved·Partial outage

LaunchDarkly has confirmed that the underlying platform issue has been fully resolved on their end (at Oct 21, 2025 – 03:00 PDT). Following their resolution, we have removed our temporary workaround and verified full restoration of normal functionality across all services, including admin.nextstep.is

  • Feature flag evaluations are now running on the standard configuration.

  • All functionality is operating normally with no residual degradation.

  • No data loss was observed during this incident.

We will continue with routine monitoring, but no further impact is expected.

Thank you for your patience during this incident.

Tue, Oct 21, 2025, 08:46 PM
(1 month ago)
·
Affected components
admin.nextstep.is
Updates

Resolved

LaunchDarkly has confirmed that the underlying platform issue has been fully resolved on their end (at Oct 21, 2025 – 03:00 PDT). Following their resolution, we have removed our temporary workaround and verified full restoration of normal functionality across all services, including admin.nextstep.is

  • Feature flag evaluations are now running on the standard configuration.

  • All functionality is operating normally with no residual degradation.

  • No data loss was observed during this incident.

We will continue with routine monitoring, but no further impact is expected.

Thank you for your patience during this incident.

Tue, Oct 21, 2025, 08:46 PM

Monitoring

We’ve been informed by LaunchDarkly of a workaround for their ongoing platform incident. We have applied this workaround, and admin.nextstep.is is accessible again. Feature flag evaluations are functioning via the workaround.

  • No data loss observed.

  • Some non-critical LaunchDarkly functions (e.g., analytics or scheduled flag changes) may still be delayed while the vendor fully resolves their incident.

  • We’re actively monitoring stability and error rates.

Tue, Oct 21, 2025, 01:47 AM(18 hours earlier)

Identified

We’re currently experiencing a service disruption with LaunchDarkly’s platform. According to their status page:

  • Elevated error rates and delays were identified in several components, including event ingestion pipelines, scheduled flag changes, and analytics.

  • Although the core Flag Delivery Network and APIs show “Operational”, other non-core services are marked as “Degraded Performance”.

We use LaunchDarkly to manage feature flags, which allows us to:

  • Roll out new features gradually (for example to a small percentage of users first) so we can monitor and ensure everything works smoothly.

  • Hide or disable new features instantly if something goes wrong (“kill switch” capability) — without needing to make big code changes or redeploy.

  • Make sure we deploy features with less risk, and deliver improvements more safely and quickly.

Because of this, when LaunchDarkly isn’t working properly, our system (admin.nextstep.is) can’t reliably decide which features should be active, and therefore can’t respond to requests as usual.

Impact on admin.nextstep.is

  • Because our system depends on real-time flag evaluation from LaunchDarkly, admin.nextstep.is is not accessible at this time.

  • Normal user access, feature toggles, and backend functionality are currently blocked pending resolution of the flag service.

  • We have not observed data loss, but user operations cannot proceed while the flag infrastructure is degraded.

What We’re Doing
  • We’re assessing alternate fallback behaviours (e.g., cached flag values or degraded mode) but these may not restore full functionality immediately.

  • We will provide further updates as soon as we receive them and are monitoring continuously.

Mon, Oct 20, 2025, 08:47 PM(4 hours earlier)
Powered by

Something not quite right?
We appreciate your feedback. Reach out to us at info@jesusfilm.org, and we'll look into it promptly.